If you are into using Magic Lantern on your Canon 5D Mark III, you have probably stayed away from the 1.2.3 firmware update due to its incompatibility. Well, it was announced today that Magic Lantern is now working on the 5D III with the firmware 1.2.3, but if you are the cautious type, you may still want to wait before trying it out.